Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 26, 2025 - 02:00 UTC
Scheduled
Dear Customer, As part of our ongoing efforts to enhance security, performance, and compliance, we will be upgrading production infrastructure in the US-East-1 region during our scheduled maintenance window.
Overview of the Change We are migrating key backend systems to new infrastructure running the latest supported operating system (Windows Server 2022). This ensures we continue to meet security, performance, and vendor support standards.
Expected Impact During the migration, you may experience the following: Temporary disruptions or slow performance when accessing the application Intermittent interruptions to active sessions Limited availability of certain features These impacts are expected to be brief and will be closely monitored by our engineering team.
Reason for the Upgrade The current operating system (Windows Server 2012 R2) is no longer supported by Microsoft and AWS, meaning it no longer receives regular security patches. Migrating to Windows Server 2022 helps us maintain a secure and compliant infrastructure that protects your data and ensures long-term reliability.
Precautionary Steps Taken We have already completed thorough testing and validation in our UAT environments across all regions. The production servers have been pre-configured and are ready for the switchover. This update does not include live customer-specific servers, which will be handled separately in collaboration with our Customer Experience teams. SQL Servers are not impacted as they are already running on the latest supported platform.
Post-Migration After the upgrade: Systems will be monitored to ensure stability. Old servers will be decommissioned after a one-month observation period.
Need Help or Have Questions? If you have any concerns or require assistance during or after the migration, please contact our support team. We’re here to help and will continue to provide updates as needed. Thank you for your continued trust and partnership.
Posted Apr 16, 2025 - 07:46 UTC
This scheduled maintenance affects: Engage, Public API, Core Services (NA- Core Services), and Space Planning (NA - Space Planning).